- fix issue when building in separate build dir
[openocd.git] / src / Makefile.am
index ff0eb6e519fbe5307b68a8448891ce1726bed1d4..502a63d50c28cdfeb1ad44ddec748d5d692febec 100644 (file)
@@ -6,11 +6,10 @@ else
 MAINFILE = main.c jim.c
 endif
 
-
 openocd_SOURCES = $(MAINFILE) openocd.c
 
 # set the include path found by configure
-INCLUDES = -I$(top_srcdir)/src/helper \
+INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/helper \
        -I$(top_srcdir)/src/jtag -I$(top_srcdir)/src/target -I$(top_srcdir)/src/xsvf -I$(top_srcdir)/src/server \
        -I$(top_srcdir)/src/flash -I$(top_srcdir)/src/pld $(all_includes)
 
@@ -71,7 +70,7 @@ FTD2XXLIB =
 endif
 endif
 
-openocd_LDADD = $(top_builddir)/src/xsvf/libxsvf.a \
+openocd_LDADD = $(top_builddir)/src/startup.o $(top_builddir)/src/xsvf/libxsvf.a \
        $(top_builddir)/src/target/libtarget.a $(top_builddir)/src/jtag/libjtag.a \
        $(top_builddir)/src/helper/libhelper.a \
        $(top_builddir)/src/server/libserver.a $(top_builddir)/src/helper/libhelper.a \
@@ -79,10 +78,7 @@ openocd_LDADD = $(top_builddir)/src/xsvf/libxsvf.a \
        $(top_builddir)/src/pld/libpld.a \
        $(FTDI2232LIB) $(FTD2XXLIB) $(MINGWLDADD) $(LIBUSB)
 
-       
-       
 nobase_dist_pkglib_DATA = \
-       tcl/commands.tcl  \
        tcl/bitsbytes.tcl  \
        tcl/chip/atmel/at91/aic.tcl  \
        tcl/chip/atmel/at91/at91sam7x128.tcl  \
@@ -98,3 +94,9 @@ nobase_dist_pkglib_DATA = \
        tcl/mmr_helpers.tcl  \
        tcl/readable.tcl  
 
+# Convert .tcl to object
+
+$(top_builddir)/src/startup.o: $(top_srcdir)/src/startup.tcl
+       abs_builddir=`cd $(top_builddir) && pwd` && \
+       cd $(top_srcdir)/src &&  \
+       ${OBJCOPY} -I binary -O ${OBJCOPY_FORMAT} -B ${OBJCOPY_ARCH} startup.tcl $$abs_builddir/src/startup.o

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)