Move TCL script files -- Step 1 of 2:
[openocd.git] / src / Makefile.am
index d04308e5249fa0bb5ac3c96784549a4e700e4eab..6b78d0922f990c3f1a09492698d31f2e97c3cd9d 100644 (file)
@@ -1,3 +1,6 @@
+SUBDIRS = helper jtag xsvf svf target server flash pld
+
+lib_LTLIBRARIES = libopenocd.la
 bin_PROGRAMS = openocd
 
 if ECOSBOARD
@@ -6,23 +9,39 @@ else
 MAINFILE = main.c
 endif
 
-openocd_SOURCES = $(MAINFILE) openocd.c
+openocd_SOURCES = $(MAINFILE) 
+openocd_LDADD = libopenocd.la
+
+libopenocd_la_SOURCES = openocd.c
 
 # set the include path found by configure
-INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/helper \
-       -I$(top_srcdir)/src/jtag -I$(top_srcdir)/src/target -I$(top_srcdir)/src/xsvf -I$(top_srcdir)/src/server \
-       -I$(top_srcdir)/src/flash -I$(top_srcdir)/src/pld $(all_includes)
+AM_CPPFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_srcdir)/src/helper \
+       -I$(top_srcdir)/src/jtag \
+       -I$(top_srcdir)/src/target \
+       -I$(top_srcdir)/src/xsvf \
+       -I$(top_srcdir)/src/svf \
+       -I$(top_srcdir)/src/server \
+       -I$(top_srcdir)/src/flash \
+       -I$(top_srcdir)/src/pld
 
 # pass path to prefix path
-openocd_CPPFLAGS = \
+libopenocd_la_CPPFLAGS = \
  -DPKGLIBDIR=\"$(pkglibdir)\" \
- -DPKGBLDDATE=\"`date +%F-%R`\" \
- -DPKGBLDREV=\"`$(top_srcdir)/guess-rev.sh`\" \
- @CPPFLAGS@
+ -DPKGBLDDATE=\"`date +%F-%R`\"
+
+if RELEASE
+libopenocd_la_CPPFLAGS += -DRELSTR=\"Release\" -DPKGBLDREV=\"\"
+else
+libopenocd_la_CPPFLAGS += -DRELSTR=\"svn:\" -DPKGBLDREV=\"`$(top_srcdir)/guess-rev.sh $(top_srcdir)`\"
+endif
+
+# add default CPPFLAGS
+libopenocd_la_CPPFLAGS += $(AM_CPPFLAGS) $(CPPFLAGS)
 
 # the library search path.
-openocd_LDFLAGS = $(all_libraries) 
-SUBDIRS = helper jtag xsvf target server flash pld
+libopenocd_la_LDFLAGS = $(all_libraries) 
 
 if IS_MINGW
 MINGWLDADD = -lwsock32
@@ -46,54 +65,31 @@ else
 if JLINK
 LIBUSB = -lusb
 else
-LIBUSB =
-endif
-endif
-
-if IS_WIN32
-if FTD2XXDIR
-FTD2XXLDADD = @WITH_FTD2XX@/FTD2XX.lib
+if RLINK
+LIBUSB = -lusb
 else
-FTD2XXLDADD = -lftd2xx
-endif
+if VSLLINK
+LIBUSB = -lusb
 else
-FTD2XXLDADD = -lftd2xx 
+LIBUSB =
+endif
 endif
-  
-if FT2232_FTD2XX
-FTD2XXLIB = $(FTD2XXLDADD)
-else
-if PRESTO_FTD2XX
-FTD2XXLIB = $(FTD2XXLDADD)
-else
-FTD2XXLIB =
 endif
 endif
 
-openocd_LDADD = $(top_builddir)/src/xsvf/libxsvf.a \
-       $(top_builddir)/src/target/libtarget.a $(top_builddir)/src/jtag/libjtag.a \
-       $(top_builddir)/src/helper/libhelper.a \
-       $(top_builddir)/src/server/libserver.a $(top_builddir)/src/helper/libhelper.a \
-       $(top_builddir)/src/flash/libflash.a $(top_builddir)/src/target/libtarget.a \
-       $(top_builddir)/src/pld/libpld.a \
-       $(FTDI2232LIB) $(FTD2XXLIB) $(MINGWLDADD) $(LIBUSB)
+libopenocd_la_LIBADD = \
+       $(top_builddir)/src/xsvf/libxsvf.la \
+       $(top_builddir)/src/svf/libsvf.la \
+       $(top_builddir)/src/pld/libpld.la \
+       $(top_builddir)/src/jtag/libjtag.la \
+       $(top_builddir)/src/flash/libflash.la \
+       $(top_builddir)/src/target/libtarget.la \
+       $(top_builddir)/src/server/libserver.la \
+       $(top_builddir)/src/helper/libhelper.la \
+       $(FTDI2232LIB) $(MINGWLDADD) $(LIBUSB)
+
+if HTTPD
+libopenocd_la_LIBADD += -lmicrohttpd
+endif
 
-nobase_dist_pkglib_DATA = \
-       tcl/bitsbytes.tcl                       \
-       tcl/chip/atmel/at91/aic.tcl             \
-       tcl/chip/atmel/at91/at91sam7x128.tcl    \
-       tcl/chip/atmel/at91/at91sam7x256.tcl    \
-       tcl/chip/atmel/at91/pmc.tcl             \
-       tcl/chip/atmel/at91/rtt.tcl             \
-       tcl/chip/atmel/at91/usarts.tcl          \
-       tcl/chip/st/stm32/stm32.tcl             \
-       tcl/chip/st/stm32/stm32_rcc.tcl         \
-       tcl/chip/st/stm32/stm32_regs.tcl        \
-       tcl/cpu/arm/arm7tdmi.tcl                \
-       tcl/cpu/arm/arm920.tcl                  \
-       tcl/cpu/arm/arm946.tcl                  \
-       tcl/cpu/arm/arm966.tcl                  \
-       tcl/cpu/arm/cortex_m3.tcl               \
-       tcl/memory.tcl                          \
-       tcl/mmr_helpers.tcl                     \
-       tcl/readable.tcl
+MAINTAINERCLEANFILES = Makefile.in

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)