flash/nor: flash driver and cfg for SAM E54, E53, E51 and D51
[openocd.git] / src / flash / nor / Makefile.am
index d817cc69cf0ac08ae0b0419756dc3f52b8711a0e..135128ee4f1602e7206b18563a0375080130a263 100644 (file)
@@ -1,56 +1,83 @@
-include $(top_srcdir)/common.mk
-
-noinst_LTLIBRARIES = libocdflashnor.la
-libocdflashnor_la_SOURCES = \
-       core.c \
-       tcl.c \
+noinst_LTLIBRARIES += %D%/libocdflashnor.la
+%C%_libocdflashnor_la_SOURCES = \
+       %D%/core.c \
+       %D%/tcl.c \
        $(NOR_DRIVERS) \
-       drivers.c
+       %D%/drivers.c \
+       $(NORHEADERS)
 
 NOR_DRIVERS = \
-       aduc702x.c \
-       at91sam4.c \
-       at91sam4l.c \
-       at91samd.c \
-       at91sam3.c \
-       at91sam7.c \
-       avrf.c \
-       cfi.c \
-       efm32.c \
-       em357.c \
-       faux.c \
-       lpc2000.c \
-       lpc288x.c \
-       lpc2900.c \
-       lpcspifi.c \
-       mdr.c \
-       non_cfi.c \
-       ocl.c \
-       pic32mx.c \
-       spi.c \
-       stmsmi.c \
-       stellaris.c \
-       stm32f1x.c \
-       stm32f2x.c \
-       stm32lx.c \
-       str7x.c \
-       str9x.c \
-       str9xpec.c \
-       tms470.c \
-       virtual.c \
-       fm3.c \
-       dsp5680xx_flash.c \
-       kinetis.c \
-       mini51.c \
-       nuc1x.c
-
-noinst_HEADERS = \
-       core.h \
-       cfi.h \
-       driver.h \
-       imp.h \
-       non_cfi.h \
-       ocl.h \
-       spi.h
+       %D%/aduc702x.c \
+       %D%/aducm360.c \
+       %D%/ambiqmicro.c \
+       %D%/at91sam4.c \
+       %D%/at91sam4l.c \
+       %D%/at91samd.c \
+       %D%/at91sam3.c \
+       %D%/at91sam7.c \
+       %D%/ath79.c \
+       %D%/atsamv.c \
+       %D%/atsame5.c \
+       %D%/avrf.c \
+       %D%/bluenrg-x.c \
+       %D%/cc3220sf.c \
+       %D%/cc26xx.c \
+       %D%/cfi.c \
+       %D%/dsp5680xx_flash.c \
+       %D%/efm32.c \
+       %D%/em357.c \
+       %D%/esirisc_flash.c \
+       %D%/faux.c \
+       %D%/fespi.c \
+       %D%/fm3.c \
+       %D%/fm4.c \
+       %D%/jtagspi.c \
+       %D%/kinetis.c \
+       %D%/kinetis_ke.c \
+       %D%/lpc2000.c \
+       %D%/lpc288x.c \
+       %D%/lpc2900.c \
+       %D%/lpcspifi.c \
+       %D%/max32xxx.c \
+       %D%/mdr.c \
+       %D%/msp432.c \
+       %D%/mrvlqspi.c \
+       %D%/niietcm4.c \
+       %D%/non_cfi.c \
+       %D%/nrf5.c \
+       %D%/numicro.c \
+       %D%/ocl.c \
+       %D%/pic32mx.c \
+       %D%/psoc4.c \
+       %D%/psoc5lp.c \
+       %D%/psoc6.c \
+       %D%/sim3x.c \
+       %D%/spi.c \
+       %D%/stmsmi.c \
+       %D%/stellaris.c \
+       %D%/stm32f1x.c \
+       %D%/stm32f2x.c \
+       %D%/stm32lx.c \
+       %D%/stm32l4x.c \
+       %D%/stm32h7x.c \
+       %D%/str7x.c \
+       %D%/str9x.c \
+       %D%/str9xpec.c \
+       %D%/tms470.c \
+       %D%/virtual.c \
+       %D%/w600.c \
+       %D%/xcf.c \
+       %D%/xmc1xxx.c \
+       %D%/xmc4xxx.c
 
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+NORHEADERS = \
+       %D%/core.h \
+       %D%/cc3220sf.h \
+       %D%/cc26xx.h \
+       %D%/cfi.h \
+       %D%/driver.h \
+       %D%/imp.h \
+       %D%/non_cfi.h \
+       %D%/ocl.h \
+       %D%/spi.h \
+       %D%/msp432.h

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)