FLASH/NOR: Remove useless file lpc2000.h
[openocd.git] / src / flash / nor / Makefile.am
index 211366b812d3a44f744701a457af9ad4cd2b8473..7d11bcd59eb5ba9d31f91b2c1519108dc82874f3 100644 (file)
@@ -1,7 +1,15 @@
-AM_CPPFLAGS = -I$(top_srcdir)/src
+AM_CPPFLAGS = \
+       -I$(top_srcdir)/src \
+       -I$(top_builddir)/src
 
 noinst_LTLIBRARIES = libocdflashnor.la
 libocdflashnor_la_SOURCES = \
+       core.c \
+       tcl.c \
+       $(NOR_DRIVERS) \
+       drivers.c
+
+NOR_DRIVERS = \
        aduc702x.c \
        at91sam3.c \
        at91sam7.c \
@@ -15,19 +23,20 @@ libocdflashnor_la_SOURCES = \
        non_cfi.c \
        ocl.c \
        pic32mx.c \
+       spearsmi.c \
        stellaris.c \
        stm32x.c \
        str7x.c \
        str9x.c \
        str9xpec.c \
-       tms470.c
+       tms470.c \
+       virtual.c
 
 noinst_HEADERS = \
-       at91sam7.h \
-       at91sam3.h \
-       avrf.h \
+       core.h \
        cfi.h \
-       lpc2000.h \
+       driver.h \
+       imp.h \
        lpc288x.h \
        non_cfi.h \
        ocl.h \

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)