Convert to non-recursive make
[openocd.git] / src / helper / Makefile.am
index c9479b43edb18aba62a6f098f952e75d63059262..362389436c07cea1a17d5c69c034a3a591d23c93 100644 (file)
@@ -1,64 +1,49 @@
-include $(top_srcdir)/common.mk
-
-METASOURCES = AUTO
-noinst_LTLIBRARIES = libhelper.la
-
-if ECOSBOARD
-CONFIGFILES = time_support_ecos.c
-else
-CONFIGFILES = options.c time_support_common.c
-endif
-
-
-
-libhelper_la_SOURCES = \
-       binarybuffer.c \
-       $(CONFIGFILES) \
-       configuration.c \
-       log.c \
-       command.c \
-       time_support.c \
-       replacements.c \
-       fileio.c \
-       util.c \
-       jim-nvp.c
+noinst_LTLIBRARIES += %D%/libhelper.la
+
+%C%_libhelper_la_CPPFLAGS = $(AM_CPPFLAGS) $(LIBUSB1_CFLAGS)
+
+%C%_libhelper_la_SOURCES = \
+       %D%/binarybuffer.c \
+       %D%/options.c \
+       %D%/time_support_common.c \
+       %D%/configuration.c \
+       %D%/log.c \
+       %D%/command.c \
+       %D%/time_support.c \
+       %D%/replacements.c \
+       %D%/fileio.c \
+       %D%/util.c \
+       %D%/jep106.c \
+       %D%/jim-nvp.c \
+       %D%/binarybuffer.h \
+       %D%/configuration.h \
+       %D%/ioutil.h \
+       %D%/list.h \
+       %D%/util.h \
+       %D%/types.h \
+       %D%/log.h \
+       %D%/command.h \
+       %D%/time_support.h \
+       %D%/replacements.h \
+       %D%/fileio.h \
+       %D%/system.h \
+       %D%/jep106.h \
+       %D%/jep106.inc \
+       %D%/jim-nvp.h
 
 if IOUTIL
-libhelper_la_SOURCES += ioutil.c
+%C%_libhelper_la_SOURCES += %D%/ioutil.c
 else
-libhelper_la_SOURCES += ioutil_stubs.c
+%C%_libhelper_la_SOURCES += %D%/ioutil_stubs.c
 endif
 
-libhelper_la_CFLAGS =
+%C%_libhelper_la_CFLAGS =
 if IS_MINGW
 # FD_* macros are sloppy with their signs on MinGW32 platform
-libhelper_la_CFLAGS += -Wno-sign-compare
+%C%_libhelper_la_CFLAGS += -Wno-sign-compare
 endif
 
-noinst_HEADERS = \
-       binarybuffer.h \
-       configuration.h \
-       ioutil.h \
-       util.h \
-       types.h \
-       log.h \
-       command.h \
-       time_support.h \
-       replacements.h \
-       fileio.h \
-       system.h \
-       bin2char.c \
-       jim-nvp.h
-
-EXTRA_DIST = startup.tcl
-
-BIN2C = bin2char$(EXEEXT_FOR_BUILD)
-
-BUILT_SOURCES = $(BIN2C)
-
-$(BIN2C): bin2char.c
-       ${CC_FOR_BUILD} ${CFLAGS_FOR_BUILD} $(srcdir)/bin2char.c -o $@
-
-CLEANFILES = bin2char$(EXEEXT_FOR_BUILD)
-
-MAINTAINERCLEANFILES = $(srcdir)/Makefile.in
+STARTUP_TCL_SRCS += %D%/startup.tcl
+EXTRA_DIST += \
+       %D%/bin2char.sh \
+       %D%/update_jep106.pl

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)