configure: remove --enable-libusb0 option, rework libusb selection
[openocd.git] / src / jtag / drivers / Makefile.am
index 30251be155d794921322d88c09c598fd117b94b8..22bc89bbcad443556a74ad21ddb5685ffd017d81 100644 (file)
@@ -19,18 +19,15 @@ SUBDIRS=
 # Standard Driver: common files
 DRIVERFILES += driver.c
 
-if USB
-DRIVERFILES += usb_common.c
-endif
-
 if USE_LIBUSB1
 DRIVERFILES += libusb1_common.c
-else
+endif
 
 if USE_LIBUSB0
+DRIVERFILES += usb_common.c
+if !USE_LIBUSB1
 DRIVERFILES += libusb0_common.c
 endif
-
 endif
 
 if BITBANG

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)