Include files required to rebuild the HTTP web pages in distribution.
[openocd.git] / src / server / Makefile.am
index a41e93201499955c1c4f64c2aaa70e6ea2336640..2a723a6bdcc2db047b40c515ef6204e97ca4e726 100644 (file)
@@ -1,5 +1,40 @@
-INCLUDES = -I$(top_srcdir)/src/helper -I$(top_srcdir)/src/target -I$(top_srcdir)/src/flash $(all_includes)
+AM_CPPFLAGS = \
+       -I$(top_srcdir)/src/helper \
+       -I$(top_srcdir)/src/target \
+       -I$(top_srcdir)/src/flash \
+       -I$(top_srcdir)/src/jtag  \
+       -DPKGLIBDIR=\"$(pkglibdir)\"
+
 METASOURCES = AUTO
-noinst_LIBRARIES = libserver.a
+noinst_LTLIBRARIES = libserver.la
 noinst_HEADERS = server.h telnet_server.h gdb_server.h
-libserver_a_SOURCES = server.c telnet_server.c gdb_server.c
+libserver_la_SOURCES = server.c telnet_server.c gdb_server.c
+
+if HTTPD
+libserver_la_SOURCES += httpd.c
+endif
+
+libserver_la_CFLAGS =
+if IS_MINGW
+# FD_* macros are sloppy with their signs on MinGW32 platform
+libserver_la_CFLAGS += -Wno-sign-compare
+endif
+
+# tcl server addons
+noinst_HEADERS += tcl_server.h
+libserver_la_SOURCES += tcl_server.c
+
+if HTTPD
+nobase_dist_pkglib_DATA = $(wildcard $(srcdir)/httpd/*.tcl $(srcdir)/httpd/*.css $(srcdir)/httpd/menu_cuts/*.png)
+endif
+
+EXTRA_DIST = \
+       httpd/readme.txt \
+       httpd/menu.xml \
+       httpd/menu.xsl \
+       httpd/build.sh \
+       httpd/html2tcl.sh \
+       httpd/Stylizer.java \
+       httpd/Stylizer.class
+
+MAINTAINERCLEANFILES = Makefile.in

Linking to existing account procedure

If you already have an account and want to add another login method you MUST first sign in with your existing account and then change URL to read https://review.openocd.org/login/?link to get to this page again but this time it'll work for linking. Thank you.

SSH host keys fingerprints

1024 SHA256:YKx8b7u5ZWdcbp7/4AeXNaqElP49m6QrwfXaqQGJAOk gerrit-code-review@openocd.zylin.com (DSA)
384 SHA256:jHIbSQa4REvwCFG4cq5LBlBLxmxSqelQPem/EXIrxjk gerrit-code-review@openocd.org (ECDSA)
521 SHA256:UAOPYkU9Fjtcao0Ul/Rrlnj/OsQvt+pgdYSZ4jOYdgs gerrit-code-review@openocd.org (ECDSA)
256 SHA256:A13M5QlnozFOvTllybRZH6vm7iSt0XLxbA48yfc2yfY gerrit-code-review@openocd.org (ECDSA)
256 SHA256:spYMBqEYoAOtK7yZBrcwE8ZpYt6b68Cfh9yEVetvbXg gerrit-code-review@openocd.org (ED25519)
+--[ED25519 256]--+
|=..              |
|+o..   .         |
|*.o   . .        |
|+B . . .         |
|Bo. = o S        |
|Oo.+ + =         |
|oB=.* = . o      |
| =+=.+   + E     |
|. .=o   . o      |
+----[SHA256]-----+
2048 SHA256:0Onrb7/PHjpo6iVZ7xQX2riKN83FJ3KGU0TvI0TaFG4 gerrit-code-review@openocd.zylin.com (RSA)